Register To Comment
Results 1 to 8 of 8

Thread: HV servo and NanoTwo v3 question.

  1. #1
    Retroman's Avatar
    Roboteer

    Status
    Offline
    Name
    Paul H
    Robots
    Pullover V2 (AW), Leopold (BW) & 1/3 of a Feather (Pushover)
    Location
    Gtr Manchester
    Posts
    131
    Hey guys, after some servi reliability issues at Botfest, I've decided to upgrade to High Voltage servos for the weapon, the trouble im having is; With the HV servo connected to the NanoTwo, everything goes haywire, random movements of both servo and drive, and servo movement make the motors spin briefly...

    Plug the old servo in and all works fine until it overheats and starts the twitching and convulsing again.

    Have I broke something? Is the servo goosed? Or is this more likely a TX issue?

    Thanks in advance for any help.

  2. #2
    RogueTwoRobots's Avatar
    Roboteer

    Status
    Offline
    Name
    Jamie McHarg
    Robots
    Drumroll II, Carcinus, Onyx & Coyote
    Location
    Aberdeen, Scotland
    Posts
    3,961
    Is the servo plugged straight into the NanoTwo? I'm not fully up to speed with the NanoTwo specs, but if your servo is taking voltage from the battery through the NanoTwo BEC, it will be drawing too much current I'd guess, causing the signal to drop in and out.

  3. #3
    Retroman's Avatar
    Roboteer

    Status
    Offline
    Name
    Paul H
    Robots
    Pullover V2 (AW), Leopold (BW) & 1/3 of a Feather (Pushover)
    Location
    Gtr Manchester
    Posts
    131
    Yeah, it's plugged straight into the NanoTwo servo/bind port, as the nano is ESC and RX combined I'm not sure whether a separate BEC for the servo would be possible... it would also eat into the remaining few grams I have spare, but that's the setup that's doing in the beetle.

    It'd be a shame to have to use a BEC, it would spoil the reason for using the v3 in the first place.

    Wait.... could I just run the power straight from the battery and use the v3 for signal? Why didn't I think of this yesterday?!

  4. #4
    Shakey's Avatar
    Member

    Status
    Offline
    Name
    Alex
    Robots
    Far, far too many (100+).
    Location
    Fleet, UK
    Posts
    435
    "Wait.... could I just run the power straight from the battery and use the v3 for signal? Why didn't I think of this yesterday?!" The Servo port on the ESC already works this way on a v3, it simply passes the power lines directly to the servo.

    What servo are you trying to use with it, and what is your battery?

  5. #5
    Retroman's Avatar
    Roboteer

    Status
    Offline
    Name
    Paul H
    Robots
    Pullover V2 (AW), Leopold (BW) & 1/3 of a Feather (Pushover)
    Location
    Gtr Manchester
    Posts
    131
    I thought that was how it worked, but I've taken the live feed from just faster the fuse/link and it behaves much better, there's still the occasion 1/2 turn of a wheel here and there, but plugged straight into the v3 it could almost cross the arena in on weapon control...

    It's an 'Orona DS929HV' High volt servo and 2s LiPo.

  6. #6
    voorsk's Avatar
    Roboteer

    Status
    Offline
    Name
    Graham
    Robots
    AW: Suspicious Houmous, Sprouting Potato, Fermented Melon
    Location
    Stockport, UK
    Posts
    30
    total guess.. drawing too much power? no idea what a tgy306 pulls in comparison

  7. #7
    Sam_DRT's Avatar
    Roboteer

    Status
    Offline
    Name
    Sam Griffin
    Robots
    Concussion (HW) Candy (AW)
    Location
    Dorset
    Posts
    7
    I tried using the same servo in my first ant, it's just a very noisy servo (lots of electrical interference). A few people with better electrical knowledge than me tried sorting it out but ended up going with a TGY-EX5252MG with a 5v regulator instead. Shakey can confirm if he visits this thread again.
    I haven't tried other models, but I'm avoiding Corona servos from now on.
    Last edited by Sam_DRT; 23rd August 2018 at 03:23.

  8. #8
    Retroman's Avatar
    Roboteer

    Status
    Offline
    Name
    Paul H
    Robots
    Pullover V2 (AW), Leopold (BW) & 1/3 of a Feather (Pushover)
    Location
    Gtr Manchester
    Posts
    131
    Ah right ok, that's good to know Sam, luckily I only got a couple for testing, and they were pretty cheap so no real loss.

    Thanks for all the help and answers everyone!

Register To Comment

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •