Register To Comment
Results 1 to 7 of 7

Thread: Advice on a LXRobotics Battleswitch

  1. #1
    Hey, realised we've never posted on here before so we should introduce ourselves! We've been busy building away for the past year or so on our machine Vortex, we were at Gloucester last year having a nightmare with our drive system and after a long winter we're getting into to putting the machine back together. It's a two man team between myself and George and we're hopefully getting there, this year we hope to cause some havoc on the live scene.

    Within Vortex there's a Motenergy ME0708 that we've been putting off running for ages, but finally the time has come to get the thing working. We've got it wired up and tried getting the solenoids to click on and off the other day, but we seem to have hit a wall getting the Battleswitch to control our solenoids.

    The way it's wired is the battery goes out to a fuse and the link, which returns into the Battleswitch power input. From the output side of one channel of the Battleswitch we go to the two low power terminals of the solenoid, and those should energise the coil in turn closing the large solenoid switch and powering up the motor (or as we were testing it, you should hear the solenoid click). The Battleswitch lights up, the main power LED comes on and we tested the input to confirm we were getting voltage across the terminals. The other two diagnostic LEDs just flash constantly however. We know from the website that these should tell us the switching status of the Battleswitch, but I can't find anywhere on the LX site that tells you the code to decipher the patterns of the two diagnostic LEDs. They both flash continuously much like a receiver does before it's bound to a transmitter, which would make me think the Battleswitch might not be configured correctly to switch on both/either channels from a receiver command.

    At the moment we've only set up one solenoid to one channel in order to test out the switch but eventually the Battleswitch will need to turn on two solenoids simultaneously (using both channels) from a command on the controller. Right now we're planning to use the throttle being lifted from zero to max to activate the switch. I read on a post here saying that the initial configuration of these switches was to be off at a centered stick and activated at stick up/down so we tried this on the right stick but still got nothing.

    Does anyone have any advice on this or know where to find the guide for working out what the two diagnostic LEDs are saying? I know there's code libraries listed on the LX page but I don't think they have what we're looking for.


    Last edited by Team Phantom; 3rd April 2018 at 23:23.

  2. #2
    Hi Sean
    Welcome to the FRA site
    I had never heard of battleswitch but it looks interesting and I might buy
    one to use in my Robot.
    It sounds like you have narrowed it down to the battleswitch ie the solenoids
    work via other means.
    Are the battleswiches suited to solenoid operation-who else uses them?.
    One point I can help with is-there should be no fuse before the removable link.

  3. #3
    I have no experience with these battleswitch things, but I can give you a place to start (apologies if you have already tried something).

    It looks like a flashing light means no signal from the receiver. (see link below)

    I would have a look at the signal with an oscilloscope.
    If you don't have a scope, plug in a servo to check the receiver is working. If the servo is working as expected, plug in the battleswitch to the receiver and check the wiring to the battleswitch (if there are LEDs flashing, there must be power so check the signal wire carefully).

    Could you give us a link to what you have? I just want to make sure I am looking at the right thing.

    ps. If you haven't already, you should use a flyback diode across the solenoid to stop voltage spikes. This doesn't really help with this issue though.

  4. #4

    I believe the solenoids are suited for operation and I believe they may have been used on Kan-Opener for the drive motors back in the day however not 100% sure. Information was more readily available when first purchased a while back however there nowhere I can seem to find the relevant info on statuses of flashing LEDs.

  5. #5
    Currently doubt this is the case as when the battleswitch is without the external power source, the power LED lights however your theory ould be right so I will test the signal quality to see if the signal is operating as expected with a scope.

    Also the battleswitch we are using is an LX Robotics one found in link ( ). I will test the signal quality to see if the signal is operating as expected.

  6. #6

  7. #7
    Aha, that's interesting! Ours never gets out of the flashing lights stage, so it may not be happy with the receiver signal. This is starting to look like the most likely cause, will need to get George to look that over as he's the black magic and sparks side of things. The solenoids should be fine, I gave them a quick resistance check across the switching coil the other day and the results were reasonable and even between the two we have, so this is looking like our culprit.

    We'll report back if we find anything.

    Last edited by Team Phantom; 6th April 2018 at 21:36.

Register To Comment

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts