Register To Comment
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: Wiring a Battleswtich

  1. #21
    Max's Avatar
    Member

    With the battleswitch make sure you are wiring it like this: https://www.dimensionengineering.com...ch-diagram.jpg. Just replace the motor with your automotive relay.

  2. #22
    Quote Originally Posted by overkill View Post
    That is exactly what I would expect if the switch was wired correctly and in the off state. Just to be sure, does the motor run if you bypass the switch output with a length of wire? If it does, the power wiring is definitely OK.

    The Turnigy switch instructions mention that it turns on when the radio channel its connected to passes 50%. Can you plug a servo into that channel and see it move fully in both directions?
    The motor ran when I bypassed the switch, made a video of testing the servo and both switches:





    Quote Originally Posted by Max View Post
    With the battleswitch make sure you are wiring it like this: https://www.dimensionengineering.com...ch-diagram.jpg. Just replace the motor with your automotive relay.
    Already done that. My only guess is that this connection is wrong but I'm not sure how else I could do it:


  3. #23
    OK, that seems to eliminate everything apart from the switches

  4. #24
    I'll order another one, see if it is the switch :/

  5. #25
    Max's Avatar
    Member

    For some odd reason all the diagrams I can find about the turnigy switch want the receiver and the main load to have a "common ground"- maybe that's an issue
    With the battleswitch, could you upload a clear picture showing how it is wired to the complete system? I can't quite wrap my head around how you've done it.

  6. #26
    mrsam's Avatar
    Roboteer

    There's a wiring diagram that Nick did for me on my build diary, might be worth a look to see if there's anything you can do differently.

  7. #27
    I don't think a common earth is *required* for the Turnigy switch, but it couldn't hurt to try it at this point. This is the diagram that Chris refereed to:



    Its pretty much the same as the diagram on the HK site. I always use a BEC to power the receiver so there is always a common earth whether its needed or not.

  8. #28

  9. #29
    mrsam's Avatar
    Roboteer

    Hi guys, also having a problem with the turnigy switch, I've wired it to an 850 motor via an automotive relay following Nick's diagram as best I could. Not getting anything at all so either I've wired it wrong or there's something wrong with the switch or relay, any help would be great. The relay I'm using is http://www.sunhold.com/product_2.php...O3=59&Vcode=31and here's a pic of how I've wired it all up, not all that clear but if you can spot any problems with it that's a help.
    Last edited by mrsam; 26th July 2014 at 11:42.

  10. #30
    mrsam's Avatar
    Roboteer

    So after a bit of testing still nothing, it's not the tx or rx and I've tried with 2 different batteries, it's either that I've wired it wrong or there's a problem with the relay or switch. Here's a top view of the relay with the numbers and symbols, if anybody can tell me how to wire it up using that so I can see if I've done it right that would be great.

Register To Comment

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •