Register To Comment
Page 10 of 11 FirstFirst ... 891011 LastLast
Results 91 to 100 of 101

Thread: 300A VESC in the works, feature suggestions wanted

  1. #91
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    I have now made up one of the logic boards and started testing it out. Should hopefully get it connected to the power board tonight!

    As you might have guessed this is going to be a two part ESC, but with a difference. The logic board is actually going to be on a longish cable ~30cm so that you can keep all your logic boards, receiver, etc in the same place, reducing cable clutter. It also makes the power boards smaller and therefore it is easier to fit the controller into a bot.
    They are connected by a microfit cable which I can supply in 150mm or 300mm.
    They look like this: 2017-08-30 17_50_35-45132-0810 Molex _ Mouser United Kingdom.pngAs they are locking they should stay on through big hits just fine.
    Last edited by TechAUmNu; 30th August 2017 at 19:38.

  2. #92
    Roboteer

    Status
    Offline
    Name
    N/A
    Robots
    The Unnamed, Bourbon, Deadlock
    Location
    UK
    Posts
    125
    Post Thanks / Like
    That sounds like a bad idea. Usually with high speed signals you want everything nice and close, not wrapped around all the noise sources you get in a robot.

  3. #93
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    It's not really high speed... I will be testing it out before to see how bad the noise is. If needed I can add a shield to the cable which would remove the problem.

  4. #94
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    Going to use some shielded cat6 cable instead since they connectors are smaller and include a nice shield for each twisted pair.

  5. #95
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    Managed to figure out a problem that was driving me crazy. As it was only outputting high side pwm. Until I found a little option that was in the GUI... fml.

    Made a new version of bldc tool with support for my silly currents. (Old version only lets you set 200A max)



    With some luck I should be able to get a test board fully working by the end of the week!

    I also decided to just put the logic board stuff onto the power board since it was proving too awkward connecting them. So will need to design a new board for all that. Which I was planning on doing anyway.

  6. #96
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    So it turned out that it was not that option after all, since after turning it on it still didn't work!

    Turned out that I kinda forgot to connect the pins on my board... oops!


    Here is the bodge I had to do to fix it.


    After fixing that mishap I plugged everything in and hozza it moves the motor! Although more jumps back and forward would be a better way to describe it. This is because I haven't yet connected the phase voltage sense wires and current sense, once I add that tomorrow it will hopefully have a better chance of completing a circle!

  7. #97
    kane's Avatar
    Roboteer

    Status
    Offline
    Name
    Kane Aston
    Robots
    Behemoth Minimoth
    Location
    Hertfordshire, UK
    Posts
    1,386
    Post Thanks / Like
    Have you looked at vesc tool rather than bldc tool. The new software runs much better for me. Www.vesc-project.com

    Also you might want to look at testing off a battery so that regen doesn't blow up your psu.
    Last edited by kane; 21st September 2017 at 23:29.
    Kane Aston
    http://www.makerobotics.com

    Co-owner and builder of BEHEMOTH

  8. #98
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    Yeah I am just looking at it now, didn't actually notice it was finally out. Should hopefully improve performance on FOC with the new firmware. It also supports 3 current shunts which is a welcome addition.

    I don't really want to test from a battery yet as any shorts will destroy the whole board. I just turn off regen in the settings.
    Have a bunch of 70A+ power supplies for testing before I move on to using a battery.

  9. #99
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    Large bag of 8mm bullet connectors arrived today!


    Spent some time putting proper wires to the board with some connectors to make my life a bit easier. Then put on the shunt resistors and the.. oh the current shunt amplifiers are the wrong size... fail. So I have ordered the correct ones, which don't get here till monday So in the meantime I am going to just look more closely at the pwm outputs and phase voltage sampling.

    Over the weekend I will layout the hopefully final board for the A200S version (3 Fets per phase leg(18 total), 1 driver per 6 fets (3 total)) which is going to be the first board. I don't personally have a use case for the A450S yet and with a new series of RW coming up I need to get the lower current one working first so people can actually have something in hand.


  10. #100
    TechAUmNu's Avatar
    Roboteer

    Status
    Offline
    Name
    Euan Mutch
    Robots
    Triforce(HW) (in progress) A450S (ESC) (in progress)
    Location
    Edinburgh, UK
    Posts
    181
    Post Thanks / Like
    Tonight I have been doing the layout for the new board for the A200S version. I have finished component placement and just moving on to routing which should be done by the end of the weekend.

    The new version is a massive improvement on what I had before, with lots of improvements from my testing of the first set of boards.



Register To Comment

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •